AutoItScript

+Clients
  • Content count

    750
  • Joined

  • Last visited

2 Followers

About AutoItScript

  • Rank
    Community Regular
  • Birthday December 16

IPS Marketplace

  • Resources Contributor
    Total file submissions: 5

Profile Information

  • Gender
    Not Telling
  • Location
    Birmingham, UK
  1. Thanks, I'll take a look at the ipv6 thing.
  2. The cron task command returns immediately if it's already running and it generally is coded so that it takes around 45 seconds to run. Which means that you are missing out on about 10-15 seconds worth of processing. You can do a script to run from cli that attempts re-running the cron command every second so that you minimise the downtime. It only slightly speeds things up, but I think it's faster than using the browser option as that adds http delays in as well. #!/bin/bash while : do /usr/bin/php -d memory_limit=-1 -d max_execution_time=0 /var/www/vhosts/......./task.php a0b84115c9f762de7e1f33466cd5e389 sleep 1 done Replace the command with your own cron string.
  3. Yep. The default still can't do automatic http->https checks, and unnecessarily proxies every request. This mod was purely for helping a site become https safe and can in fact be run with the proxy "off" so that it only rewrites http images where there is a valid https version - this is a great way of using it too as you can uninstall it without any changes needed later. From testing on my own board the vast majority of images that users post as http do actually have https versions already there! The built-in solution just proxies every single image which is a scenario that I don't need or particularly understand
  4. Hmm, it hooks everywhere that calls a certain image parsing function. IPS changed that code it last release so maybe that function doesn't get called on downloads picture files anymore. :/ Does the IPS image proxy also ignore Downloads? If so it seems the likely cause and maybe needs a bug report.
  5. Ah, you can't do that when tethering. It gets replaced with a blue hotspot link that takes you into settings if you touch it. I'll try it when I disconnect
  6. I was going to chime in and say that I installed such a plugin on my board because I find it so annoying to browse this site on my phone and get RSI scrolling back to the top. Must check out this double-tap you speak of! Edit: Hmm, can't seem to find anything that does that. What am I clicking the web address at the top? Just asks me to overtype the address.
  7. board

    It's been back for a while.
  8. Yeah I was going to log a bug/feedback ages ago because the archiving runs under the normal task scheduler every 5 mins and only does a few posts each cycle. When I tried it I moved it to every minute and then edited the task to do a few thousand at a time. Otherwise the estimated time was measured in weeks :/ It should be a background task really like the post rebuilds after a new upgrade. In the end I realised that archived topics couldn't be searched and that searches on IPS 4 happen in a separate table now so archiving wasn't as important so I unarchived everything.
  9. My plugin does exactly that. It checks for a https version if available before falling back to proxying.
  10. I've found that stuff like that doesn't really help most of the korean spammers appear to actually be human!
  11. I'm using the current version on my 4.1.7 site - it works fine Moving back over won't affect the already posted content. IIRC I specifically stopped my code from touching any board-related urls because I knew an IPS solution was in the works and I didn't want to rewrite their urls just in case it broke something. I may do an update that allows you to rewrite their urls and do a post rebuild if that's useful?
  12. Arrgh the marketplace is driving me crazy, how hard can it be to upload a zip file Edit: Should be fixed now...
  13. Possibly. I've no idea how attachments work but I can have a look if the relevant bits are exposed when my code runs.
  14. Ah sorry, I meant the "paste without formatting" button. That's gone.
  15. There used to be one but it's vanished. Not sure if it's a bug or they thought it was no longer required with the recent changes. My members have been asking for it too since my 4.1 upgrade,