z1000-forum.de

Classifieds Extended Permissions

9 posts in this topic

%7Boption%7D



File Name: Classifieds Extended Permissions

File Submitter: z1000-forum.de

File Submitted: 21 May 2012

File Category: Commerce

Supported Versions: IP.Board 3.3.x, IP.Board 3.4.x



This hook adds permission settings for minimum posts and registration days(feel free suggesting your ideas about it).


Features:

  • Per package settings
  • No template edits
  • Full language support


Installation instructions:
  • Log in to your IP.Board Admin CP and visit the System tab -> Applications & Modules -> Manage Hooks page. In the 'Install a New Hook' section, browse to the XML file included with these instructions and click Open. Once it installs this hook, be sure to enable it!



here to download this file

Maxxius likes this

Share this post


Link to post
Share on other sites

Hi.

On v3.3.4 of IPB, this hook produces an error when you view the board on a mobile device (with the mobile skin).

The error reads:

Fatal error : Method launcher_link does not exist in cfdsExtPermsSkinClassifieds in /home/********/public_html/forun/**********/sources/classes/output/publicOutput.php on line 3731

Any idea what is causing this?

Share this post


Link to post
Share on other sites

With IPB 3.4.0 i have this error

Fatal error: Method launcher_link does not exist in cfdsExtPermsSkinClassifieds in /home/madbox/public_html/foro/admin/sources/classes/output/publicOutput.php on line 3992

please help

Share this post


Link to post
Share on other sites

seems that is not an error in my hook. my hook overwrites the skin_classifieds template file, so that it appears in the error message. but the real error behind that message is that some code or hook that references a template named 'launcher_link' in the skin_classifieds template group. but there is no template like this in the default classifieds release and also not in my hook.

i predict that the error is still there even if you disable my hook. please try that and if the error is gone then try to reinstall my hook. sorry but there is nothing more i can do at this time.

Share this post


Link to post
Share on other sites

I have tested this mod on latest IP.Board 3.4.5 and I get no errors. Though I have one problem which quite big. When a member who does not meet the standarts of creating a new add there's just a redirect to the page with Oops something went wrong text AND there is no error message. Member does not get informed that he either has too few posts or has not been registered for long enough. I get just the error which leaves me wondering what is wrong and why I cannot create a new ad.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.