Marcher Technologies

RSS Management Application

268 posts in this topic


Marcher, Your app Imports feeds have Tags functionality?



Working on record and topic tagging upon import(the field already exists in this apps table), at this time tutorials is supported for import tagging... unless i misunderstand and you want to tag the frontend feed landing?
I'll have to add something for that if so ;)

Share this post


Link to post
Share on other sites

Marcher, I'm somewhat confused after testing your demo.

When I hover over an RSS feed title, I get the hovercard which displays the content of the feed, nicely formatted. Great!

However, when I click the RSS title link, I expect to be taken to a page that contains full page view of that RSS feed, similarly formatted as the hovercard, so I can easily read say 15 entries.

Instead I am taken to the default RSS display mode, as determined by my web browser. In other words, it looks horrible in Chrome (XML code), and nice in Safari. This seems very limiting in my opinion.

Could there be an icon perhaps next to the title that brings up a full-screen-width hovercard (like a lightbox) at least. Something like the YouTube fullscreen icon. I would still rather the title links takes the user directly to a dynamically generated 'page' on my site that they can bookmark for later use (in other words they can use my site as a full-screen RSS reader if there browser doesn't have it).

Share this post


Link to post
Share on other sites

Marcher, I'm somewhat confused after testing your demo.



When I hover over an RSS feed title, I get the hovercard which displays the content of the feed, nicely formatted. Great!



However, when I click the RSS title link, I expect to be taken to a page that contains full page view of that RSS feed, similarly formatted as the hovercard, so I can easily read say 15 entries.



Instead I am taken to the default RSS display mode, as determined by my web browser. In other words, it looks horrible in Chrome (XML code), and nice in Safari. This seems very limiting in my opinion.



Could there be an icon perhaps next to the title that brings up a full-screen-width hovercard (like a lightbox) at least. Something like the YouTube fullscreen icon. I would still rather the title links takes the user directly to a dynamically generated 'page' on my site that they can bookmark for later use (in other words they can use my site as a full-screen RSS reader if there browser doesn't have it).



.... i LIKE that.
I already have the data locally.... make the icons full-screen in-site rss readers.... .... I would think i should still link to the source though... some feedback?

Share this post


Link to post
Share on other sites

You already have the link to the source, and I agree it should stay. The original source feed could be optional though as some admins might not want anyone knowing their RSS feed URL's as they'd copy them into their own competing websites.

When you hover over the RSS icon in your mod (orange thing with white curves) it says "View Source: IPS News". So the source link's already positioned where I think user's would expect to see it.

Share this post


Link to post
Share on other sites

Im getting an issue in 3.3

500 internal server error when i try and run the import of a feed that validated fine

this is from the cpanel error log


[Mon Apr 02 15:29:22 2012] [error] [client 180.76.5.52] File does not exist: /home/**/public_html/404.shtml
[Mon Apr 02 15:29:22 2012] [error] [client 180.76.5.52] script not found or unable to stat: /home/**/public_html/forumdisplay.php
[Mon Apr 02 15:29:08 2012] [error] [client 66.249.71.212] File does not exist: /home/**/public_html/404.shtml
[Mon Apr 02 15:29:08 2012] [error] [client 66.249.71.212] script not found or unable to stat: /home/**/public_html/member.php
[Mon Apr 02 15:29:00 2012] [error] [client 90.198.205.115] File does not exist: /home/**/public_html/500.shtml, referer: http://www.**.co.uk/admin/index.php?adsess=efd72ee64ee009cfd506985556578a03&app=rss&module=import&section=databases&do=rssimport_validate&rss_app_id=1
[Mon Apr 02 15:28:37 2012] [error] [client 90.198.205.115] File does not exist: /home/**/public_html/404.shtml
[Mon Apr 02 15:28:37 2012] [error] [client 90.198.205.115] File does not exist: /home//public_html/admin/undefined

im thinking a resource usage issue or a 3.3 issue any help would be brill

Share this post


Link to post
Share on other sites

Im getting an issue in 3.3



500 internal server error when i try and run the import of a feed that validated fine



this is from the cpanel error log




[Mon Apr 02 15:29:22 2012] [error] [client 180.76.5.52] File does not exist: /home/**/public_html/404.shtml


[Mon Apr 02 15:29:22 2012] [error] [client 180.76.5.52] script not found or unable to stat: /home/**/public_html/forumdisplay.php


[Mon Apr 02 15:29:08 2012] [error] [client 66.249.71.212] File does not exist: /home/**/public_html/404.shtml


[Mon Apr 02 15:29:08 2012] [error] [client 66.249.71.212] script not found or unable to stat: /home/**/public_html/member.php


[Mon Apr 02 15:29:00 2012] [error] [client 90.198.205.115] File does not exist: /home/**/public_html/500.shtml, referer:

http://www.**.co.uk/...te&rss_app_id=1

[Mon Apr 02 15:28:37 2012] [error] [client 90.198.205.115] File does not exist: /home/**/public_html/404.shtml


[Mon Apr 02 15:28:37 2012] [error] [client 90.198.205.115] File does not exist: /home//public_html/admin/undefined



im thinking a resource usage issue or a 3.3 issue any help would be brill



...... I am trying to reproduce this(really am.... I developed this latest vs and tested it on both ends of the version fence)
First, I'm not calling or even referencing any of the files listed there...
Secondly, This is on my live site.... I just checked that error_log and php_error_log.... not one mention of anything to do with this application...
Thirdly, it was developed in strict php mode...
Thusly, I'll need access to debug.... PM me.

Share this post


Link to post
Share on other sites

.... i LIKE that.


I already have the data locally.... make the icons full-screen in-site rss readers.... .... I would think i should still link to the source though... some feedback?




Anymore on this because I want to purchase this if implemented.

Share this post


Link to post
Share on other sites

Working on it... and working around the fact that /rss/{app}/ means something... I may have to double up the furl or change it on this application in whole to sidestep this.

Share this post


Link to post
Share on other sites

One question before purchase...

When I manually add an article I can choose to not show it on the front page. If I automate the creation of articles through RSS import do I have that option as well?

Share this post


Link to post
Share on other sites

Just purchased this. When I click on "Create New RSS Import Stream" I get...

Fatal error: Out of memory (allocated 34340864) (tried to allocate 4096 bytes) in /home/bluecana/public_html/admin/applications/forums/sources/classes/topics.php on line 727

I'm hosted with Invision.

Share this post


Link to post
Share on other sites

Just purchased this. When I click on "Create New RSS Import Stream" I get...



Fatal error[color=#000000]: Out of memory (allocated 34340864) (tried to allocate 4096 bytes) in [/color]/home/bluecana/public_html/admin/applications/forums/sources/classes/topics.php[color=#000000] on line [/color]727



I'm hosted with Invision.



Just Clicking Create New Stream does that?
trying to allocate 4096 bytes(4 kb) for the Forums dropdown it is running out of memory.... that's not really normal...
Need better specifics to help.. or access, the error literally makes 0 sense.... I could potentially see a literal insanity of forums causing a little extra memory usage, but that makes little sense for 4kb usage to go left...

One question before purchase...



When I manually add an article I can choose to not show it on the front page. If I automate the creation of articles through RSS import do I have that option as well?



Yes, in a sense, i did not add an additional configuration for the single database, I tied it into this option:
Records Approved?

Share this post


Link to post
Share on other sites

Just Clicking Create New Stream does that?


trying to allocate [color=#000000]4096 bytes(4 kb) for the Forums dropdown it is running out of memory.... that's not really normal...[/color]


[color=#000000]Need better specifics to help.. or access, the error literally makes 0 sense.... I could potentially see a literal insanity of forums causing a little extra memory usage, but that makes little sense for 4kb usage to go left...



It works when I click "import to database" so that should be fine.

Yes, in a sense, i did not add an additional configuration for the single database, I tied it into this option:


Records Approved?



Not what I need :( I want them to show up in their category but not on the front page.

Another thing I noticed that I hope you can address. The URL field does not appear to be populated using this import function.

Share this post


Link to post
Share on other sites

[/color]



[color=#000000]It works when I click "import to database" so that should be fine.[/color]





Not what I need :sad: I want them to show up in their category but not on the front page.



Another thing I noticed that I hope you can address. The URL field does not appear to be populated using this import function.



Noted, recoding how I'm doing this anyway to use a serialized array... form will be fun though(is irrelevant on every other database).
RSS Import Add Link To Post? you need to leave the value filled with {url} or change it as desired... default is:


[url={url}]View the full article[/url]


Upon loading the form, if you mean other please specify.

Share this post


Link to post
Share on other sites


[url={url}]View the full article[/url]


Upon loading the form, if you mean other please specify.



Not sure. I change my template so that the article title goes directly to the off site article instead of to the full article within my site. I use this...

{$data['records'][0]['url']}

But that value seems to be blank for imported items or specifically it just links to my main board page (which strikes me as a default value when it is blank).

Oh, and sorry, but by "noted" did you mean that you are planning on adding a "show on front page" option? Without it I can't make use of this unfortunately. I use my front page for manually posted articles and want to have a category dedicated to these automated imports.

If that isn't possible perhaps there is a way I can modify the front page template to exclude this category?

Share this post


Link to post
Share on other sites

Not sure. I change my template so that the article title goes directly to the off site article instead of to the full article within my site. I use this...



{$data['records'][0]['url']}



But that value seems to be blank for imported items.



OK, Custom fields support at this time is rather limited(another item I am recoding)...
You basically need to be able to select a single field to inject the external URL to on import, at this time only the Title field, Content Field, and a selection for the picture field are present, also noted.

Share this post


Link to post
Share on other sites

Is there a way I can contact you? I tried PM but I think your inbox is full.



Thanks for that, should have room now(also about hip-deep in this applications code).
There are faster methods listed on my profile here as a note.

Share this post


Link to post
Share on other sites

I think I found a small bug. I want to associate an image with each feed. So I uploaded an image to the "RSS Import Record Picture" box. When I click "save" I get a "move failed" error. Am I doing something wrong or is this a bug?

Share this post


Link to post
Share on other sites

I think I found a small bug. I want to associate an image with each feed. So I uploaded an image to the "RSS Import Record Picture" box. When I click "save" I get a "move failed" error. Am I doing something wrong or is this a bug?



... hrmm, is /uploads/rss/ writable?(note to self, add code to check this upon install/upgrade)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.