-RAW-

It's the Final Countdown

176 posts in this topic

The time on this is all wrong!

I made a countdown to 6AM (+9.30 GMT) and it shows 15 hours, 30 minutes - the time here is 1:00AM - 10.5 hours out!

%7Boption%7D

%7Boption%7D

Checked the server time, it is set correctly, checked the forum board time, it is set correctly, all posts show the correct time.

Help?

Share this post


Link to post
Share on other sites

requesting a new hooking point/type/style or whatever lol. A ticker that scrolls through each countdown, much like Adriano's 'latest blogs ticker'



Rich

Share this post


Link to post
Share on other sites

It installs fine and I can get to the settings, however, it produces a front page error of:


Fatal error: Call to a member function finalCountdownIncludeJs() on a non-object in /home/staff/public_html/forums/hooks/finalCountdownIncludeJs_7b5c57006e2169f4624eb4233b681284.php on line 8

I have rebuilt all templates and options in cache management, but the problem it still there.

When I uninstall final countdown, the board operates normally again.

What's the fix?

Share this post


Link to post
Share on other sites

requesting a new hooking point/type/style or whatever lol. A ticker that scrolls through each countdown, much like Adriano's 'latest blogs ticker'



http://community.inv...entries-ticker/

Rich



The JS code needed for this is already in place, so it shouldn't be too hard to add this. Will take a look at this for the next feature update :)


It installs fine and I can get to the settings, however, it produces a front page error of:




Fatal error: Call to a member function finalCountdownIncludeJs() on a non-object in /home/staff/public_html/forums/hooks/finalCountdownIncludeJs_7b5c57006e2169f4624eb4233b681284.php on line 8



I have rebuilt all templates and options in cache management, but the problem it still there.



When I uninstall final countdown, the board operates normally again.



What's the fix?



You don't have your board "IN_DEV" by any chance, do you?
If not, go to Look & Feel > Template Tools > Rebuild Master Skin Data, tick off "Rebuild HTML" and "It's the Final Countdown", and click "Rebuild".

Share this post


Link to post
Share on other sites

The JS code needed for this is already in place, so it shouldn't be too hard to add this. Will take a look at this for the next feature update :smile:




You don't have your board "IN_DEV" by any chance, do you?





I rebuilt everything a few times, but that didn't work. Should I rebuild them in a certain order?

How can I tell for certain if it's in the "IN_DEV" mode?

Share this post


Link to post
Share on other sites

I use jQuery quite a bit on the system and the way you have setup the application just will not play nice.

I tried to have your stuff call the loaded jQuery but no matter what I do it simply will not load.

Share this post


Link to post
Share on other sites

I rebuilt everything a few times, but that didn't work. Should I rebuild them in a certain order?



How can I tell for certain if it's in the "IN_DEV" mode?



If you're not sure if it is IN_DEV, it probably isn't.

Did you use the "Rebuild Master Skin Data" the first time? To my understanding you recached your skin sets. These two options does not perform the same tasks.
If you could give me ACP access to your board, I can fix this for you.


I use jQuery quite a bit on the system and the way you have setup the application just will not play nice.



I tried to have your stuff call the loaded jQuery but no matter what I do it simply will not load.



I encountered several issues when I tested this with 3rd party skins that used jQ, and the way I did it here was the only way I got it working on both non-jQ and jQ skins.
Do you have any other suggestions on how I could do it?

Share this post


Link to post
Share on other sites

Make all of the fiddling optional I setup JQuery with noConflict ready for use simply calling it as jQuery.... works for all the other stuff I have like accordian et al

Share this post


Link to post
Share on other sites

I just wish it was that easy, but when I try that, I end up with this.



I will have another go in a while and see what I can cook up.

Share this post


Link to post
Share on other sites

OK what people using JQuery need to do is find in the hglobalTemplate


  {parse template="includeJS" group="global" params="$jsModules"}

Add before (change as required for where you want to load jQuery...


  <script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.7.0/jquery.min.js"></script>

  <script type="text/javascript">

   jQuery.noConflict();

  </script>

I do other stuff install any jQuery add-ons after the initial main jQuery load as an example my actual setup is...


  <script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.7.0/jquery.min.js"></script>

  <script type="text/javascript" src="/js/jquery.newsticker.js"></script>

  <script type="text/javascript">

   jQuery.noConflict();

   jQuery(document).ready

   (

    function()

    {

	 if( jQuery("#news").length )

	 {

	  jQuery("#news").newsTicker(8000);

	 }

    }

   );

  </script>

Share this post


Link to post
Share on other sites

OK that has the front end working, now to work out why the admin Test Countdowns is broken.

Share this post


Link to post
Share on other sites

Few things

[*]Using the drag'n'drop to reorder the items is not sticking [*]It would be nice to be able to clone an existing entry [*]There needs to be an end date for displaying the 'finished' message (so that the countdown is then obsolete automatically) [*]The admin test is throwing "syntax error timezone: , " app=finalCountdown&module=test&section=test in firebug


Share this post


Link to post
Share on other sites

OK what people using JQuery need to do is find in the hglobalTemplate



  {parse template="includeJS" group="global" params="$jsModules"}

Add before (change as required for where you want to load jQuery...


  <script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.7.0/jquery.min.js"></script>

  <script type="text/javascript">

   jQuery.noConflict();

  </script>

I do other stuff install any jQuery add-ons after the initial main jQuery load as an example my actual setup is...


  <script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.7.0/jquery.min.js"></script>

  <script type="text/javascript" src="/js/jquery.newsticker.js"></script>

  <script type="text/javascript">

   jQuery.noConflict();

   jQuery(document).ready

   (

	function()

	{

	 if( jQuery("#news").length )

	 {

	  jQuery("#news").newsTicker(8000);

	 }

	}

   );

  </script>



That is pretty much what I did yesterday. The problem was that the custom skin I'm testing this on loads jQ after my code, and that wipes out the countdown code as that extends jQuery. When a new version if jQ is loaded, without using the check I have ( ! window.jQuery && document.write() ), window.jQuery/window.$ is cleared before setting it up again, taking $.countdown/jQuery.countdown with it.

Until IPS decide to add a native jQuery loading method, we'll have to live with this.


OK that has the front end working, now to work out why the admin Test Countdowns is broken.



I know why those don't work. It broke when I fixed the issue Extreame had.

Share this post


Link to post
Share on other sites

i have this error now

Fatal error: Call to a member function finalCountdownIncludeJs() on a non-object in /home/www/0b0be9dfa4fc9e3bd3e4e79bcbcd0712/web/forums/hooks/finalCountdownIncludeJs_6cf2e3f3895555dbc6b9843ff458daad.phpon line 8

how can i fix this

my webiste is down now http://www.ikusa.fr/forums/

edit :
i have delete the hook It's the Final Countdown
and desactivate the module until you give me a solution

same thing as jackflash

Edited by boboss78

Share this post


Link to post
Share on other sites

[s]i have this error now



Fatal error: Call to a member function finalCountdownIncludeJs() on a non-object in /home/www/0b0be9dfa4fc9e3bd3e4e79bcbcd0712/web/forums/hooks/finalCountdownIncludeJs_6cf2e3f3895555dbc6b9843ff458daad.phpon line 8



how can i fix this



my webiste is down now

http://www.ikusa.fr/forums/

edit :


i have delete the hook

It's the Final Countdown


[color=#969A9D][size=3]and desactivate the module until you give me a solution[/size][/color][/s]



[size=3][color=#000000]same thing as [/color][/size]

jackflash

Not sure why you guys get that errors. Well, I know what causes it, but not why.
For some reason the templates aren't inserted, or not written to cache, which never happened to me nor my beta testers.

I will release an update soon which shows a nicer error if skin templates are missing, rather than crashing the forum.


As I use IP Content for my homepage, could you port this as a block?



I will familiarize myself with IP.Content soon, and get a content block added.

Share this post


Link to post
Share on other sites

How do you change the background of the timer? Currently it's a white/grayesh gradient and does not work well with my skin.

Share this post


Link to post
Share on other sites

How do you change the background of the timer? Currently it's a white/grayesh gradient and does not work well with my skin.



You can change that in ACP > Look & Feel > [Select your skin] > skin_finalCountdown > finalCountdownIncludeJs

Share this post


Link to post
Share on other sites

If you only want a plain flat background color, you adjust the first one, which is:

background: #fcfcfc; /* Old browsers */

And remove the next two

background: -moz-linear-gradient(top, #fcfcfc 0%, #e5e5e5 100%); /* FF3.6+ */

background: -webkit-gradient(linear, left top, left bottom, color-stop(0%,#fcfcfc), color-stop(100%,#e5e5e5)); /* Chrome,Safari4+ */

Meowcious likes this

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.