Pete T

Download: Shoutbox

2,865 posts in this topic

When editing a shout we are transfered to the shoutbox application ... is it possible to change this, editing a shout and stay on top of the forum app?
IPB 3.3.4 & Shoutbox 1.3.3

Share this post


Link to post
Share on other sites

hello I see that there's a filter problem to view the archive on a site and I have been unable to fix it again as this did happen before that I did not record of how I fixed it (I forgot how) but I think that there is a field or so that have incorrect data in the database causing the filter to load forever. I did try Database Index Checker in ACP but it seems no support for it and it does for Database Checker?

Share this post


Link to post
Share on other sites

This is covered in the Shoutbox FAQ.




Thank you.

Must be be doing something wrong as still cant get it to work. Thanks anyway.....will just go back to a different skin.

Share this post


Link to post
Share on other sites

No, due to changes IPS made to the javascript needed to load the editor.



It's a pity ... but thanks anyway for your quick answer :)

Share this post


Link to post
Share on other sites

hello I see that there's a filter problem to view the archive on a site and I have been unable to fix it again as this did happen before that I did not record of how I fixed it (I forgot how) but I think that there is a field or so that have incorrect data in the database causing the filter to load forever. I did try Database [u]Index[/u] Checker in ACP but it seems no support for it and it does for Database Checker?




What exactly are you doing in the archive when you encounter the issue? It seems to work OK for me.

Share this post


Link to post
Share on other sites

on global hook using theme 2 with Top of each page as position, what determines the width of the text entry bar?
would it be in skin_shoutbox_hooks - hookGlobalShoubox

want to see if I can widen it a bit and align the buttons to the right

Share this post


Link to post
Share on other sites

The input and buttons are this code in that template:

						<td class='altrow' valign='top' colspan='2'>

							<input type='text' id='shoutbox-global-shout' size='70' class='input_text' />

							<input type='button' id='shoutbox-submit-button' value='{$this->lang->words['shout']}' class='input_submit' />

							<input type='button' id='shoutbox-clear-button' value='{$this->lang->words['clear']}' class='input_submit alt' />

							<input type='button' id='shoutbox-refresh-button' value='{$this->lang->words['refresh']}' class='input_submit alt' />

							<if test="$this->settings['shoutbox_allow_smilies']"> <input type='button' id='shoutbox-smilies-button' value='{$this->lang->words['smilies']}' class='input_submit alt' data-clicklaunch="populateSmilies" data-scope="shoutbox" /></if>

							<if test="$this->settings['shoutbox_allow_bbcode']"> <input type='button' id='shoutbox-bbcode-button' value='{$this->lang->words['bbcode']}' class='input_submit alt' /></if>

							<input type='button' id='shoutbox-myprefs-button' value='{$this->lang->words['my_prefs']}' class='input_submit alt' />

						</td>

Share this post


Link to post
Share on other sites

Probably a stupid question but is it possible to shift the shoutbox to the top of the gallery page without to much hassle ?

Share this post


Link to post
Share on other sites

The input and buttons are this code in that template:



						<td class='altrow' valign='top' colspan='2'>

							<input type='text' id='shoutbox-global-shout' size='70' class='input_text' />

							<input type='button' id='shoutbox-submit-button' value='{$this->lang->words['shout']}' class='input_submit' />

							<input type='button' id='shoutbox-clear-button' value='{$this->lang->words['clear']}' class='input_submit alt' />

							<input type='button' id='shoutbox-refresh-button' value='{$this->lang->words['refresh']}' class='input_submit alt' />

							<if test="$this->settings['shoutbox_allow_smilies']"> <input type='button' id='shoutbox-smilies-button' value='{$this->lang->words['smilies']}' class='input_submit alt' data-clicklaunch="populateSmilies" data-scope="shoutbox" /></if>

							<if test="$this->settings['shoutbox_allow_bbcode']"> <input type='button' id='shoutbox-bbcode-button' value='{$this->lang->words['bbcode']}' class='input_submit alt' /></if>

							<input type='button' id='shoutbox-myprefs-button' value='{$this->lang->words['my_prefs']}' class='input_submit alt' />

						</td>




changing the 70 to 120 seemed to be good compromise for me, works on both theme 1 and 2 with all skins for me.
Thanks Michael.

Share this post


Link to post
Share on other sites

This question is covered in the Shoutbox FAQ.




Thanks Michael, it was set to every page (top) and even re caching did not alter it, However I changed from top to bottom and fine, changed back again to top and now on every page which is fine for me..I must read the FAQ in future :thumbsup:

Share this post


Link to post
Share on other sites

an issue randomly arose today. For whatever reason, When a shout is submitted, it does not appear until the page is refreshed. What could be causing this? How can I fix it?

I have it turned off right now, so if it is something you can take a look at, let me know and I will give you acp info so you can duplicate issue.

Share this post


Link to post
Share on other sites

Yea, I was one version behind, so I upgraded to the latest version, and the issue still existed. So, really weird man.

Share this post


Link to post
Share on other sites

It's likely caused by either a skin template having old/bad code or a javascript file being outdated. Try the steps in the Shoutbox FAQ about rebuilding the skins.

Share this post


Link to post
Share on other sites

I have actually followed all those steps in the FAQ. I rebuilt the skins, and re-cached, and am still experiencing the same issue. It appears that all my files are intact as well.

Share this post


Link to post
Share on other sites

Hey, i have the shoutbox installed on a dark theme. It has white lines running through it to seperate each shout and doesn't look brilliant. I'm just wondering what file I have to edit to change the colour.

Share this post


Link to post
Share on other sites

I have tried to add the box to:

forum index/topic index/posts

but unless you are a skinner, I don't see how this is possible for the average admin. Could you post an example of how to get the shoutbox on top of these three pages?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.